BaseCamp REST API "The remote server returned an error: (401) Unauthorized." error

Oct 9, 2009 at 4:27 AM
Edited Oct 9, 2009 at 4:28 AM

Hello team,

I tried to use this tool with original credentials. But while logging in, I'm getting "The remote server returned an error: (401) Unauthorized." error. The credentials are correct. I'm able to login with my credentials via browser, but not by this tool.

I'm using .Net technology and C# as my programming language.

Please help.

Thanks

Siva

 

Coordinator
Feb 15, 2010 at 6:22 PM

I used it with my basecamp credentials and it worked fine.  I had to use updated login credentials when they changed the web site a while back, though.

Jun 7, 2011 at 12:40 PM
Edited Jun 8, 2011 at 1:00 PM

I know this is an old post but I'm documenting what I have found in case anyone else has the same issues with 401/404 errors. Of course, as the error implies I was not using the proper credentials by using the API token instead of my actual sign on. Once I figured this out the errors changed from 401 to 404 - Not Found. The 404 error was resolved by dropping the / after my basecamp url. 

The following is what I used to connect sucessfully after several attempts.

url: make sure you use "https://yourcompanysbasecampurl.basecamphq.com" as HTTPS is standard now for Basecamp.

username: our administrator had setup our username as our email so I had to use "myemail@domain.com"

password: at first I thought this was my API token, after 401 unauthorized errors, this is actually my Basecamp account's pw not the token.

 

Hope that helps anyone that runs into the same issue!

 

Dave